Moving from OracleJDK8 to OpenJDK8 with WSO2

Posted by Rob Blaauboer on 21 Mar, 2019

It might not be well known, but Oracle has changed the nature of Oracle JDK 8. It will not be possible to use JDK 8 for commercial purposes without incurring costs (as of February 2019). But, luckily when we look at the compatibility matrix we see that OpenJDK8 is now supported as well for a number of current products.

There is a migration initiated by WSO2 to newer versions of Oracle JDK e.g. 10 and more recently 11, but there is nothing final about the support by WSO2 products. The compatibility matrix only shows OpenJDK, Adopt OpenJDK 8 (for API Manager 2.6.0) and Oracle JDK 8.

Read More

Topics: WSO2 API, API Management, OpenJDK8, OracleJDK